
6th Technology Application Standards by Content Area 

Click on your subject area below to view the TEKS your subject area is responsible for teaching.  

 

Foundations  
Technology Terminology/Acceptable Use Policy (AUP)  

 
Networking  

Basic Operations 

Math English Reading
Social 

Studies
Science 

All 
Subjects 

T1 Learn grade level appropriate technology terminology.(1E, 1H) All Subjects

T2
Teachers will review the rules included in the NEISD Acceptable 
Use Policy and model appropriate use of the computer. (3A, 3B, 
3C) **

All 
Subjects

Social 
Studies

T3
Students will sign off on the NEISD AUP and demonstrate an 
understanding of the rules when accessing NEISD computers. (3A, 
3B, 3C) **

All 
Subjects

Social 
Studies

T4
Students will not copy: 1) another individual’s electronic work, or 
2) software for which they do not have a license, or 3) copyrighted 
information that does not meet “fair use guidelines”.(3A, 3B, 3C)

All Subjects

** Social Studies teachers will review the AUP and appropriate use of the computer with 
their students early in the year. All teachers will model appropriate use and remind 
students of NEISD policies throughout the year.

N1
Log on and off the network using personal username and password
each time computer is used.(1A)

All Subjects

N2
Create, name, and save files to personal directory on the network. 
(1A, 1B, 1F) **

All 
Subjects

English

N3
Access files in personal directory and on the student shared 
directory. (1A, 1B, 1F)

All Subjects

N4
Copy files from the student shared directory to personal directory 
by copying the icon or using the Save As feature within the 
program.(1A, 1B, 1F)

All Subjects

N5
Select and print to the appropriate networked printer.(1A, 1B, 1F, 
2A)

All Subjects

** English teachers will assist students in setting up a folder for each subject area in 
their personal directories early in the year. All teachers will reinforce use of the subject 
area folders.

B1 Use My Computer or Network Neighborhood to navigate to All Subjects



Keyboarding 

available drives.(1A, 1B) 

B2
Adjust digital camera settings in order to capure quality images while 
minimizing file size (640x480 pixels, standard quality setting). Take 
pictures and upload them to a computer (2A, 2D)

Science

B3 Use the scanner to digitize images and use them within an application. 
Social 
Studies

B4
Use the Help menu to type in a keyword and/or look at the available 
list of topics. (5C)

All Subjects

B5 Use the Ctrl+Alt+Delete keys to unfreeze the computer. (1A) All Subjects

B6
Right-click on files, folders, icons, and within applications to access 
menu options. (1A)

All Subjects

B7
Delete files within personal directory by right-clicking the file icon and 
choosing delete. (1A)

All Subjects

B8 Create folders within personal directory to organize files. (1A, 1B) English

B9 
Rename files and folders within personal directory by right-clicking the 
file icon and choosing Rename. (1A, 1B)

English

B10
Adjust the view of files and folders by selecting View from the menu 
bar and choosing Large Icon, Small Icon, List, or Details. (1A, 1B)

English

B11
Organize files and folders within personal directory by selecting View 
from the menu bar, choosing Arrange Icons and making a selection. 
(1A, 1B)

English

B12 Save digital files to a CD-R. (1B, 5B) English

B13
Recognize various file formats including, but not limited to, .doc, .ppt, 
.xls, .dbf, .bmp, .jpg, .gif, .stk, .ins, .html and their associated 
applications/programs. (1D, 1E, 5A)

All Subjects

B14
Hold the Ctrl key and select text or objects not ordered consecutively 
to copy, cut or delete. (1A)

Science

B15
Hold the Shift key and select text or objects ordered consecutively to 
copy, cut, or delete. (1A)

Science

K1
Use correct posture when keyboarding and demonstrate mastery of 
proper keyboarding technique. (2A, 2B)

All Subjects

K2
Use language skills including capitalization, punctuation, spelling, 
word division, and the use of numbers and symbols as grade-level 
appropriate. (2B)

All Subjects

K3
Use a variety of software applications such as Word, Excel, or 
Inspiration to produce, proofread, and correct errors within 
documents. (2B, 7A, 7B, 7C)

All Subjects

K4
Students will keyboard 24 words per minute with 96% accuracy by 
the end of the sixth grade.(2A, 2B)

All Subjects

K5 Use one space after all punctuation marks. (2C) All Subjects

K6
Keyboard from copy (documents, textbooks, or other printed 
sources of information) (2A, 2B, 2C) 

English Reading



 

Information Acquisition and Problem Solving 
These applications are intended to be used withing the context of the content area TEKS to express ideas 

and solve problems.  
Word Processing (Word)  

Multimedia (PowerPoint) 

W1
Create a new document or open an existing one on the student-
shared directory.(7A)

English Reading

W2
Change font size, type, style (bold, italicize, underline), and 
color.(7A, 10D) 

English Reading

W3
Use the highlighter tool to highlight text with different colors. 
(NE)

English Reading

W4 
Use Alignment tools to format text (left, right, center, justify)
(7A)

English Reading

W5 Format text by using Bullets and Numbering.(7A, 10D) English Reading

W6 Create tables to structure and organize information. (7G, 10D) English Reading

W7
Use the Spelling and Grammar and Thesaurus features to edit 
documents. 

English Reading

W8

Understand AutoCorrect feature for spelling and grammar (Red 
underline – misspelling, green underline – grammar). Correct 
these by right-clicking on the underlined word(s) and selecting 
the appropriate option.(7A)

English Reading

W9 
Insert Pictures from Clipart Gallery and From File (digital 
camera, scanner, or other source).(7A, 7G, 10D)

English Reading

W10
Move and resize clipart and/or images by right-clicking on the 
image, selecting Format Picture, clicking the Layout tab, and 
choosing the appropriate Wrapping Style.(10D) 

English Reading

W11
Access available tools (standard, formatting, drawing, etc.) by 
selecting View from the menu bar and choosing Toolbars. (7F)

English Reading

W12
Use Draw tools (WordArt, Text Box, Paint bucket, Lines and 
Arrows, and AutoShapes).(7F)

English Reading

W13

Highlight/Select one or more objects and under the Draw menu 
choose: 1) Grid to unsnap or snap objects to grid, 2) Order to 
layer objects and text, 3) Rotate or Flip to change object 
orientation, 4) Group or Ungroup to combine or separate 
objects, and 5) Align and Distribute to position objects. (7F)

English Reading

W14
Adjust margins, page orientation, and vertical alignment using 
Page Setup under the File menu.(7A, 10D)

English Reading

W15 Insert Headers and Footers using the View menu. (7A, 10D) English Reading

W16 Format page by inserting Borders and Shading.(7A, 10D) English Reading

W17 Adjust spacing using Paragraph in the Format menu.(7A, 10D) English Reading

W18 Insert a Hyperlink.(NE) English Reading

Create a new presentation with multiple slides.(7D, 10A, 10D, Social 



Spreadsheet (Excel) 

M1 11B) Science Studies

M2 
Use design templates to customize presentations. (7D, 10A, 10D, 
11B)

Science
Social 
Studies

M3 
Change backgrounds by selecting Format from the menu bar and 
choosing Background.(7D, 10D)

Science
Social 
Studies

M4 Add and remove Text Boxes.(7D, 10D) Science
Social 
Studies

M5
Change the font size, type, style (bold, italicize, underline), and 
color.(7D, 10D)

Science
Social 
Studies

M6 
Use Alignment tools to format text (left, right, center, justify). 
(7D, 10D)

Science
Social 
Studies

M7 Format text by using Bullets and Numbering.(7D, 10D) Science
Social 
Studies

M8
Use the Spelling and Grammar and Thesaurus features to edit 
documents.(7D)

Science
Social 
Studies

M9 
Insert Pictures from Clipart Gallery and From File (digital 
camera, scanner, or other source). (7D, 7G, 10D)

Science
Social 
Studies

M10
Access available tools (standard, formatting, drawing, etc.) by 
selecting View from the menu bar and choosing Toolbars. (7F)

Science
Social 
Studies

M11
Use Draw tools (WordArt, Text Box, Paint bucket, Lines and 
Arrows, and AutoShapes). (7F) 

Science
Social 
Studies

M12

Select one or more objects and under the Draw menu select: 1) 
Grid to unsnap or snap objects to grid, 2) Order to layer objects 
and text, 3) Rotate or Flip to change object orientation, 4) 
Group or Ungroup to combine or separate objects, and 5) Align 
and Distribute to position objects.(7F)

Science
Social 
Studies

M13
Edit Slide Transitions and Custom Animations to enhance 
presentation.(7D, 10D)

Science
Social 
Studies

M14
Under Slide Show use Set Up Show to Loop Continuously.
(7D, 10D)

Science
Social 
Studies

M15
Use the Slide Sorter view to organize (change sequence) and 
edit presentation.(7D, 10D)

Science
Social 
Studies

M16
Remove individual slides in the Slide Sorter view by right-
clicking and choosing Delete. (7D, 10D)

Science
Social 
Studies

M17 Insert sound file or record voice into presentation.(7D, 10D) Science
Social 
Studies

M18
Insert video taken with the digital camera or video camera. (7D, 
10D)

Science
Social 
Studies

M19
Use different printing options including multiple slides per page, 
handouts, notes, and outline. (7D, 10D)

Science
Social 
Studies

M20
 

Insert a Hyperlink.(NE) Science
Social 
Studies

S1 Identify and locate cells, rows, and columns. (NE) Math



Database (Access/Works) 

Desktop Publishing (Publisher) 

S2 
Create a spreadsheet by entering text, values (numeric), and formulas. 
(7B)

Math

S3
Use Chart Wizard to create charts/graphs as grade level and task 
appropriate to express ideas 
and solve problems.(7B, 10C, 10E)

Math

S4
Adjust margins, page orientation, and vertical/horizontal alignment 
using Page Setup under the File menu.(7B, 10C, 10D)

Math

S5 Format cells by changing column width and row height.(7B, 10C, 10D) Math

S6 Insert and delete columns and rows.(7B) Math

S7 
Change the font size, type, style (bold, italicize, underline), and color. 
(10D)

Math

S8 Use the Spelling and Grammar feature to edit spreadsheets.(7B) Math

S9
Insert Pictures from Clipart Gallery and From File (digital camera, 
scanner, or other source). (7B, 10C, 10D)

Math

S10
Access available tools (standard, formatting, drawing, etc.) by selecting
View from the menu bar and choosing Toolbars.(7F)

Math

S11
Use Draw tools (WordArt, Text Box, Paint bucket, Lines and 
Arrows, and AutoShapes).(7F)

Math

S12

Highlight/Select one or more objects and under the Draw menu 
choose: 1) Grid to unsnap or snap objects to grid, 2) Order to layer 
objects and text, 3) Rotate or Flip to change object orientation, 4) 
Group or Ungroup to combine or separate objects, and 5) Align and 
Distribute to position objects.(7F)

Math

S13
Right-click on cells, columns, or rows and select Format Cells to 
change Number, Alignment, Font, Border, Patterns, or 
Protection. (10C)

Math

S14 Insert a Hyperlink.(NE) Math

D1 Open an existing database on the student-shared directory. (1A) Science

D2 Navigate through records in a table, query, or form. (10B) Science

D3 Enter data into a field in a table or form view.(7C) Science

D4
Insert Pictures into a field from Clipart Gallery and From File 
(digital camera, scanner, or other source). (7C, 7G, 10D)

Science

D5 Find a record based on defined criteria. (10B) Science

D6 Sort records. (10B) Science

D7 Use filtering tools to answer questions.(10B) Science

DP1
Select a document type and use the Publisher Wizard to choose a 
design, color scheme, and layout.(7E)

Social 
Studies

DP2 Edit needed pages and delete unnecessary ones by clicking on the 
page navigation button (lower left), selecting Edit from the menu, and 

Social 
Studies



Paint (MS Paint) 

Graphic Organizer (Inspiration) 

choosing Delete Page.(7E, 12D)

DP3 Click in the text boxes and replace text. (7E)
Social 
Studies

DP4 Use the Spelling feature to edit documents.(7E)
Social 
Studies

DP5 
Right-click on images, choose Change Picture, Picture, and Clipart 
to replace existing picture with another selection. (7E, 7G, 10D)

Social 
Studies

DP6 
Insert Pictures from Clipart Gallery and From File (digital camera, 
scanner, or other source).(7E, 7G, 10D)

Social 
Studies

DP7
Access available tools (standard, formatting, drawing, etc.) by 
selecting View from the menu bar and choosing Toolbars.(7F)

Social 
Studies

DP8 Use Draw tools to add Text Boxes, Lines, AutoShapes, etc. (7F)
Social 
Studies

DP9 
Delete Objects (text boxes, clipart, etc.) by right-clicking and 
selecting this option.(7E, 10D)

Social 
Studies

DP10
Change picture properties (color, scale, type, etc.) by right-clicking on 
the picture and choosing Change Picture.(10D)

Social 
Studies

DP11
Change frame properties (fill color, line color, border style, etc.) by 
right-clicking on the picture and choosing Change Frame.(10D)

Social 
Studies

DP12
Select Arrange to Order (layer), Align, or Rotate or Flip objects.
(10D)

Social 
Studies

DP13
Select Page Setup under the File menu to change Publication 
Layout and Page Orientation.(7E)

Social 
Studies

P1
Create original images or edit imported images by using the paint 
tools. (5A, 7F, 7G)

Science
Social 
Studies

P2 Change file format of existing image files (.bmp, .jpeg, .gif).(5A) Science
Social 
Studies

P3
Cite copyright information on an image by making a textbox 
providing copyright information and saving the edited file (stamping 
URL on an image retrieved from Internet). (3A)

Science
Social 
Studies

G1
Create a diagram or open an existing template that explains an 
idea or concept.(10D)

English Reading

G2 Insert symbols or pictures into diagram.(10D) English Reading

G3 Use the link tool to connect objects within a diagram.(10D) English Reading

G4
Change the font size, type, style (bold, italicize, underline), and 
color. (10D)

English Reading

G5 Use the Rapid Fire tool to input ideas into a diagram.(10D) English Reading

G6 Use the Spell Check tool to edit diagrams. (10D) English Reading

G7 Compile notes and ideas into outlines using the Outline View. English Reading



Internet (Netscape Communicator/Internet Explorer)  

Collaboration  

(10D)

G8 Insert hyperlinks(NE) English Reading

G9 Use Draw Tools to design and format a diagram. (7F, 10D) English Reading

G10
Select Group, Align, and Evenly Space under the Symbol 
menu to format objects within a diagram. (7F, 10D)

English Reading

G11
Select Gridlines under the Utility menu to show or hide grid.(7F, 
10D)

English Reading

G12
Select Grid Snap under the Utility menu to snap or unsnap 
objects to grid.(7F, 10D)

English Reading

G13
Layer objects by choosing Send to Back or Bring to Front from 
the Effects menu. (7F, 10D) 

English Reading

G14
Adjust page orientation to effectively print diagrams and outlines.
(10D)

English Reading

G15
Use Diagram Properties and Outline Properties under the File 
menu to change default settings within a file.(10D)

English Reading

I1 Use keyword searches to find information on a given topic.(4A, 4B)
Social 
Studies

I2 
Use Boolean search strategies to find information on a given topic.(4A, 
4B)

Social 
Studies

I3
Gather information from the websites found from search results.(4A, 
4B)

Social 
Studies

I4 
Use the Bookmark or Favorites feature to identify and save sites to 
an individual computer.(NE)

Social 
Studies

I5 

Determine whether web sites provide useful, appropriate, and valid 
information using methods including looking at the URL, identifying the 
author, looking for bibliographic information, checking associated links, 
ability to email author, listing the date the page was last updated, and 
identifying the site’s targeted audience. If needed, use the NEISD Web 
Site Evaluation Chart.(6A, 6B, 6C, 9B)

Social 
Studies

I6 
Use the web to tour virtual environments, remote locations, and/or 
explore online interactive lessons.(7H)

Social 
Studies

I7 
Communicate with other learners or experts in the field through tools 
such as: teacher email (teacher-directed only), video conferencing 
(NetMeeting), and/or interactive websites.(8A, 11C)

Social 
Studies

I8 Use acquired information in the creation of products. (NE)
Social 
Studies

I9
Recognize and identify sources of URL suffixes including, but not limited 
to, .org, .com, .edu, .gov, and .net (6C)

Social 
Studies

I10
Use the Internet as an online help source as needed to solve specific 
problems.(5C)

Social 
Studies



Communication 
Publish  

Portfolio  
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C1 
Use technology to communicate and collaborate with other students on 
group projects. (7J, 8B, 8C, 8E) 

All 
Subjects

C2 
Use any applications available in the North East ISD software load to 
create products that communicate ideas when working on group 
projects. (7J, 8E)

All 
Subjects

PB1
Display work on the computer screen, projector, television, or printer. 
(11A)

All 
Subjects

PB2 Proofread products and make improvements. (12D)
All 
Subjects

PB3
Use tools such as checklists, timelines, and rubrics to evaluate products 
and determine relevancy to task and specific lesson objectives. (9A, 
12A, 12B, 12D)

All 
Subjects

PB4
Choose appropriate fonts, colors, and graphics in order to ensure that 
products are readable when displayed on screen and/or printed. (10D)

All 
Subjects

A1
Students and teachers will select items that have been saved to the 
students’ personal network directories to store in an electronic portfolio.
(12C)

All 
Subjects


